Issue with applying via Jobnet

Minor incident Emply
10-01-2025 14:09 CET · 2 weeks, 5 days, 23 hours, 44 minutes

Updates

Resolved

The issue with the error message when attempting to apply for a position on Jobnet has been resolved. However, please note that previous job postings still displaying this error must be re-promoted.

January 30, 2025 · 13:51 CET
Issue

We are currently experiencing issues where some jobs cannot be applied for via Jobnet. We are investigating the issue further.

If you encounter a job that cannot be applied for via Jobnet, it can often be resolved by duplicating the job and promoting the duplicated listing.

January 20, 2025 · 14:09 CET

← Back