Accessing platform and carreer site

Minor incident Emply Career Site
10-03-2025 13:41 CET · 19 hours, 39 minutes

Updates

Resolved

Issue has been fixed.

March 11, 2025 · 09:20 CET
Issue

Some users may encounter difficulties accessing their platform or career site. We are actively working to resolve the issue as quickly as possible.

March 10, 2025 · 13:41 CET

← Back