We're currently experiencing performance related challenges in Emply and career sites.
Minor incident
Emply
Career Site
API
31-03-2025 09:00 CEST
· 23 hours, 32 minutes
Updates
Resolved
April 1, 2025 · 08:00 CEST
Issues with performance in Emply and on careersite is solved for now.
Sorry for the inconvenience.
Issue
March 31, 2025 · 09:29 CEST
We’re currently experiencing slow or no performance in Emply and on the career sites.
Several modules and functions like import, export and messaging is affected.
← Back