Important: Possible Service Interruptions

Major incident Emply Career Site API Emply App
04-12-2025 08:00 CET · 1 hour, 41 minutes

Updates

Resolved

Service Restored.
The issue has been resolved, and services should now be fully restored.
Please refresh your browser before logging in to ensure everything works as expected.
We will continue to monitor the situation closely and provide updates if needed.
If you experience any issues, you can always reach out to Customer Support for assistance.

December 4, 2025 · 09:32 CET
Issue

Important: Possible Service Interruptions.
Our team is working to resolve the issue and restore normal operations as soon as possible.
You may experience limited service disruptions until the situation is fully resolved.
We’ll keep you updated as progress continues.

December 4, 2025 · 08:21 CET

← Back